Saturday, 9 April 2022

Marker Editor Feedback Release

Hi!

Got some great feedback on the marker editor. It took a while and I fixed the bugs that were reported and I added some additional features (hello undo/redo!). Some other generic reported issues have also been fixed in this build.

You can download the new build from here.

Change notes:

  • Added bindable undo and redo keys to the marker editor submenu
  • Marker editor undo buffer resets on map change
  • Fixed TacO not shutting down with GW2 any more
  • Added option for TacO to show up as a windows taskbar window
  • Fixed default markers in Frostgorge Sound
  • Keys can now be bound with the combination of SHIFT and CTRL
  • Editor fix: hidden external trails can't be clicked any more
  • Marker editor now shows the guid of the edited object
  • Marker editor now shows if the edited object is external or not
  • Editor fix: Replaced some text with icons
  • Editor fix: Switching the behavior of a marker/category now functions as expected
  • Fixed a menu crash
This update brings some changes to the localization strings, non-English translations must be updated by their maintainers.

41 comments:

  1. For some reason my TacO icon doesn't show up next to the trading post in this version, works fine in r62

    ReplyDelete
    Replies
    1. Huh interesting, can you give me the log file?

      Delete
    2. Reproduced, seems to be a first-run issue, should be gone after restarting. Investigating.

      Delete
  2. I have the same problem!

    ReplyDelete
    Replies
    1. Working on it, it's got something to do with the non-larger css files, should be fixed in a bit.

      Delete
  3. Perfect as allways!

    ReplyDelete
  4. I just updated to the newest version, but i can't seem to use it.. I've lost the tabs that allowed me to hide unnecesary things in the top left next to black lion market, and I can't seem to hide the marker editor at all it is just taking up the middle of my screen

    ReplyDelete
    Replies
    1. Is that with build 63 or 64? 64 is supposed to fix this issue.

      Delete
  5. Is there a way to set a specific segment of a trail to a different color or different icons? It would be extremely helpdul in SAB where sometimes the trail can be followed loosely while at other times it needs to be followed very precisely.

    ReplyDelete
    Replies
    1. In order to do that you need separate trails. It's an optimization thing.

      Delete
  6. Is there a way to insert a break into a trail and then delete a segment, breaking the continuity between the segment before and the segment after the deleted portion?
    I want to be able to completely remove a piece of trail, as if I had hit the pause and resume buttons when originally creating the trail.

    ReplyDelete
  7. I'm currently having issues editing a trail. In the previous version I could edit a trail I was currently making if I saved it and reloaded it, but now when I do that the trail is stuck in recording mode and moving the markers doesn't move the trail (but the changes still stick). If you need me to upload the trail file somewhere I can do that.

    ReplyDelete
    Replies
    1. When I stop the recording the trail disappears.

      Delete
    2. Saving a trail should automatically create an editable trail from it currently, and yeah that may conflict a bit with the reload functionality, but it shouldn't disappear when saved... Hm.

      Delete
    3. Here I recorded a video of the issue I was having.
      I got there in the first place from not being quite sure how to get the trail to be editable. https://streamable.com/hlsx40

      Delete
    4. This is what I encountered when attempting to add points to the trail https://streamable.com/ulfn4z

      Instead of editing the newly saved trail it edited an invisible version of it. I wonder if it has something to do with recording still being active.

      Delete
    5. Ah. Make sure the fade near and fare values are set to something else than -1 (check other trails for valid ranges). I fixed this for other cases, will need to fix this as well.

      Delete
  8. Hi, great program, one thing, trying to un-tick some options but the items popupa over the tick selection so I cannot un-tick it. is there a word wrap option, the selection go so far to the right and some text lines are too long. Also is it possible to not have the map timer pop up when there is a new update. thx

    ReplyDelete
    Replies
    1. You can just overwrite your old install with the new one and that will keep all your settings, including the maptimer location/toggle status. Can you send me a screenshot of the popup issue to see how bad it is in your case? Thanks.

      Delete
  9. The problem is in the Character Growth option, the sentence is too long and pops over the tick/untick option, and its friggen annoying.

    ReplyDelete
    Replies
    1. Screenshot please, TacO on its own doesn't have a "Character Growth" section, it'll be in one of the automatically updated marker packs.

      Delete
  10. I am unable to paste my TS3 API key at all. When I used CTL+V all it puts in there is a v which I couldn't remove without closing TacO and restarting it and when I tried to type in the TS API key (which is all caps) it would only allow lower case. Also I had to try several times to paste my GW2 API in until it finally took.

    ReplyDelete
  11. I'm experiencing an issue. I have made my own set of markers, which are just the default gold diamond marker, but colored a wide array of different colors. They were edited/created in image creation software and saved in that color (i'm not using TacO to apply a different color to the default icon). However, when I place a default marker, and go to change it to one of these colored diamonds, it does not change the icon image. It WILL change it if I choose a different marker. These markers I have created are kept in a folder path of "Data/Mervil/Defaults", so I don't know if the use of the word Defaults in the path is the issue? no idea

    ReplyDelete
    Replies
    1. In general what you're doing is not a good idea for performance reasons. If you end up with too many colors your images will overload the internal texture atlas and at that point you'll be getting abysmal performance. That put aside this isn't an issue I've seen before - are you changing the images through the internal marker editor? Have you tried setting a category to the markers before editing the image?

      Delete
    2. Yes, I am changing the images via the internal marker editor (apart from hardcoding it, I'm not aware of any other ways to edit the markers).
      I haven't tried specifically setting a new category. A category already exists in my own .taco marker pack, and then it looks like that info is automatically copied/added to the poidata.xml file now automatically. Before the recent updates, I had no issues placing these markers. I would just hit the "+" button, and then using the old marker editor, just change the marker to what i wanted it to be.

      Delete
    3. Can you do a short recording to demonstrate the issue please? I'll look into it for the next release if I can repro it.

      Delete
    4. Happy to do so, just not sure how to get the video to you.

      Delete
    5. The about window has my contact email :) (Don't want to type it out here for the parsing bots to find)

      Delete
    6. I just wanted to make sure you received my email. If not, it was sent, maybe was blocked by spam filter. Please let me know if I should send it again. Thank you!

      Delete
    7. Hey, sorry, I got it but real life is being a bit messy right now. Will check it out as soon as possible, I just wasn't in front of my pc for almost a week now.

      Delete
  12. This comment has been removed by the author.

    ReplyDelete
  13. I must say: I LOVE being able to edit trails with the new editor! So good!

    Any chance you could get this working? :D

    behavior:
    1: 'Reappear on map change' - this is not implemented yet, it will be useful for markers that need to reappear if the player changes the map instance.

    ReplyDelete
  14. i can´t select my own PNG files, for marker settings. its just return to the default marker. before the new Marker Editor it works Fine for me.

    ReplyDelete
  15. The userinterface keeps bugging. Flashing so I cant click or unclick options. As well as this the markers stay on my screen even when the program is not active and cant stop it unless i shut down computer. At this stage have unloaded it.

    ReplyDelete
    Replies
    1. This seems to happen when a launcher app somehow manages to start up multiple instances of TacO. Can you check if you see multiple instances in the task manager?

      Delete
  16. Always seems like using this for the first time every time I update this.

    ReplyDelete
  17. the paste doesnt work again...

    ReplyDelete