Monday, 1 June 2020

Windows 7 fix

Hi everyone,

the last build introduced a new way of rendering TacO in windows, which should be more performant... However this meant the use of an API that's unavailable on Windows 7. This new build fixes this issue by adding a fallback to the old method. Please guys if possible update to an actually supported OS, it's for your own security as well :D

Also added a bunch of new features that were on the top of the todo that will add quality of life changes and new possibilities to marker pack creators, most importantly: markers can now have info text assigned to them, so many of the large markers with text layers can be replaced. This will ease the load on the dynamic texture atlas and help fix performance (and huge log size) issues.


In order to add an info text to a marker the info xml tag must be used. The range in which the text will be visible can be set with the infoRange xml tag. If several markers are showing text in the same area, the texts will be displayed below each other.

As always, the latest build can be downloaded from here.

Change notes:

  • Added fallback for Windows 7 - Please consider updating from a not supported OS, guys...
  • Reorganized the menu a bit to be more compact (added a submenu for tactical overlay settings)
  • Added a "Support GW2 TacO development" menu item
  • Increased the size of the dynamic texture atlas to 2048x2048, this will help with performance issues up to a point
  • Updated the update checker mechanism as it was no longer functioning correctly
  • Added the ability to add info text to markers, the text shows up below the enemy health bar
  • Added a toggle to turn marker info text on/off
  • Added global marker opacity settings (three levels: solid, transparent, faded) for in-game and map markers
  • Added a menu item to reload all markers and categories without restarting TacO
  • Added a menu item to remove all markers from the current map instance that were placed by the player
  • Range circles will no longer show up on the world map view
This update brings some changes to the localization strings, non-English translations must be updated by their maintainers.

19 comments:

  1. Thanks for the Win7 fallback :)

    ReplyDelete
  2. yea thanx too
    but now i'm using build 044 and taco ingame says its new build available to update?

    ReplyDelete
  3. Hi there, thanks for the new build! I've been getting crashes with this version just thought I'd let you know!

    Crash occurred at: 2020-06-03 12:14:24
    Build version: GW2 TacO 044.2663r
    Exception Type: c0000005
    Unresolved address: 6678D033
    Unresolved address: 6678CF26
    Unresolved address: 6678DCE1
    Unresolved address: 5E78AF4F
    Unresolved address: 5E78AEEA
    Unresolved address: 5E78AA8F
    Unresolved address: 5E78AA19
    Unresolved address: 5E78A98E
    C:\!Code\GitHub\GW2TacO\Bedrock\CoRE2\DX11Device.cpp (324)
    C:\!Code\GitHub\GW2TacO\Bedrock\CoRE2\DX11Device.cpp (441)


    Crash occurred at: 2020-06-03 12:14:46
    Build version: GW2 TacO 044.2663r
    Exception Type: c0000005
    Unresolved address: 6678D033
    Unresolved address: 6678CF26
    Unresolved address: 6678DCE1
    Unresolved address: 5E78AF4F
    Unresolved address: 5E78AEEA
    Unresolved address: 5E78AA8F
    Unresolved address: 5E78AA19
    Unresolved address: 5E78A98E
    C:\!Code\GitHub\GW2TacO\Bedrock\CoRE2\DX11Device.cpp (324)
    C:\!Code\GitHub\GW2TacO\Bedrock\CoRE2\DX11Device.cpp (441)

    ReplyDelete
    Replies
    1. Which OS are you on? If on Windows7, did you happen to download a random dcomp.dll from the internet and put it next to TacO? :D

      Delete
    2. My OS is Win 8.1, I had TacO in a dedicated folder straight from Unzip.

      I do also have regular issues with the TacO UI not aligning with the center of the screen (it gets stuck in the corner all the time), which leads me to think it might have something to do with my machine...

      Delete
  4. This immediately got flagged by Windows defender upon unzipping:
    Threat detected: Trojan:Win32/Wacatac.B!ml
    I'm guessing it's some overzealous heuristics?

    ReplyDelete
    Replies
    1. Yes I already sent it to microsoft for whitelisting, but who knows how long that's gonna take...

      Delete
  5. Not sure what the fix was for windows 7. but its still not working :(
    with my last version (Download Build 042.2533r) suddenly i only get a black screen with the marker on so i cant se any thing in game ;( so i downloaded the last version "Download Build 044.2661r" and the trouble is still the same issue

    ReplyDelete
    Replies
    1. If build 42 worked fine since its release in October then the change is going to be with your system. Go through the relevant options in the FAQ.

      Delete
    2. This comment has been removed by the author.

      Delete
    3. Well the old version 42.x did not work thats why i try the new one (44.x) but still same issues.
      I have also turned on Aero and got the latest gfx drivers.
      And now with the newest version 45.x i can see it for a micro second and then i goes away (think its quit taco prog).... :(

      Delete
    4. Send me the log file. But windows 7 black screen issues are not generally something i’m able to fix. If TacO quits we can have a look at that.

      Delete
    5. Will sure do but i dont know where to (cant find any ling to bugg report)..

      Delete
    6. Will try to post the log here....

      [2020-06-05 18:08:00] (Info) [GW2TacO] build ID: GW2 TacO 045.2703r
      [2020-06-05 18:08:00] (Info) [core] Creating classic swap chain
      [2020-06-05 18:08:00] (Info) [core] DirectX11 Device initialization successful.
      [2020-06-05 18:08:02] (Info) [gui] Successfully loaded Skin 'UI.wbs'
      [2020-06-05 18:08:02] (Info) [core] Successfully loaded D3DCompile from d3dcompiler_47.dll
      [2020-06-05 18:08:03] (Info) [GW2TacO] Initialization successful. Starting main loop here.
      [2020-06-05 18:08:03] (Info) [GW2TacO] Fetching URL: api.guildwars2.com//v2/wvw/objectives?ids=all
      [2020-06-05 18:08:03] (Info) [GW2TacO] Checking for updates
      [2020-06-05 18:08:03] (Info) [GW2TacO] Fetching URL: api.guildwars2.com//v2/maps?id=968
      [2020-06-05 18:08:03] (Info) [GW2TacO] Fetching URL: api.guildwars2.com//v2/maps?id=96
      [2020-06-05 18:08:03] (Info) [GW2TacO] Fetching URL: api.guildwars2.com//v2/maps?id=95
      [2020-06-05 18:08:03] (Info) [GW2TacO] Fetching URL: api.guildwars2.com//v2/maps?id=1099
      [2020-06-05 18:08:03] (Info) [GW2TacO] Fetching URL: api.guildwars2.com//v2/maps?id=38
      [2020-06-05 18:08:03] (Info) [GW2TacO] Latest build: 45.2703r
      [2020-06-05 18:08:49] (Info) [GW2TacO] Taco integrity: 3000, GW2 integrity: 2000
      [2020-06-05 18:08:49] (Info) [GW2TacO] Querying the API: /v2/tokeninfo
      [2020-06-05 18:08:49] (Info) [GW2TacO] Fetching URL: api.guildwars2.com//v2/tokeninfo?access_token=50505809-3D69-9842-998A-E6EB3FB4B1B8BA642B1F-4AFA-4165-91C6-CF82406FB385
      [2020-06-05 18:08:50] (Info) [GW2TacO] Querying the API: /v2/account
      [2020-06-05 18:08:50] (Info) [GW2TacO] Fetching URL: api.guildwars2.com//v2/account?access_token=50505809-3D69-9842-998A-E6EB3FB4B1B8BA642B1F-4AFA-4165-91C6-CF82406FB385
      [2020-06-05 18:08:51] (Info) [GW2TacO] Querying the API: v2/account/achievements
      [2020-06-05 18:08:51] (Info) [GW2TacO] Fetching URL: api.guildwars2.com/v2/account/achievements?access_token=50505809-3D69-9842-998A-E6EB3FB4B1B8BA642B1F-4AFA-4165-91C6-CF82406FB385
      [2020-06-05 18:10:42] (Info) [GW2TacO] Closing TacO because GW2 is not running anymore
      [2020-06-05 18:10:42] (Info) [GW2TacO] Shutting down.
      [2020-06-05 18:10:43] (Info) [core] 3 unfreed graphical resources found on exit. This is fine.
      [2020-06-05 18:10:43] (Info) [GW2TacO] Shutdown finished.

      Delete
  6. Making Trails wont Work for me. I dont See the trail on the map.

    ReplyDelete
  7. There is a bug in Taco, that places random markers in Bjorna Marches around raven ruins & Whispering depths.

    I turned all packs off and even cleaned the basic markers. but they are still there. Even after reinstall they appear after a while.

    ReplyDelete
    Replies
    1. Check to see if the keybind to place a marker isn't something that you randomly press during gameplay. Poidata.xml contains your personal markers, if you delete that and the markers disappear then you placed the markers yourself.

      Delete
    2. isnt the case. they just appear in bjorna marches in locations that i rarely go. lets see what happens if i remove some packs either from tekkit or reactive might come from there.it would be useful to deactivate marker place buttons in the future :) everytime i find a way to unbind, the next restart it is bound again.

      Delete
    3. Well first off place TacO in a folder where it has write privileges. Next to the game in Program Files is generally NOT a good idea. If the config cannot be saved, your keybinds will reset on restart.

      Delete